As an Exchange administrator, I am sure you are familiar with the kinds of the 9646 event error report in the application log. They can appear many times per day or only happen once a week. Although, it seems there is no user impact about this error, but
the Boss may have concerns about the potential issues about this error.
[Symptoms]
============
[Cause]
=========
Connection and usage limits have been placed on the Exchange store to prevent a single application or a single user from using all the available connections to the Exchange store.
Item type |
Registry object type |
Max opened per session |
ACL View |
objtACLView |
50 |
Attachment |
objtAttachment |
500 |
Attachment View |
objtAttachmentView |
500 |
Cstream |
objtCStream |
50 |
Folder |
objtFolder |
500 |
Folder View |
objtFolderView |
500 |
FX Destination Stream |
objtFXDstStrm |
50 |
FX Source Stream |
objtFXSrcStrm |
50 |
Message |
objtMessage |
250 |
Message View |
objtMessageView |
500 |
Notification |
objtNotify |
500,000 |
Rule View |
objtRulesView |
50 |
Stream |
objtStream |
250 |
[Solution]
===========
Firstly, you need to check the application log and see if the user do have the requirements to raise the store limitation for them.
For Example, some VIPs may need to keep the mailbox open on multiple clients like Outlook, OWA, Mobilities, or they have requirements to share their mailboxes to secretaries. Then you may need to raise the MaxObjsPerMapiSession value for them in order to
avoid this event error report.
1.Start Registry Editor (regedit).
2.Navigate to the following registry subkey:
\\HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
3.Right-click ParametersSystem, point to New, and then click Key. A new key is created in the console tree.
4.Rename the key MaxObjsPerMapiSession, and then press Enter.
5.Right-click MaxObjsPerMapiSession, point to New, and then click DWORD (32-bit) Value. The new value is created in the result pane.
6.Rename the key to <Object_type>, where <Object_type> is the name of the registry object type that you're modifying. For example, to modify the number of messages that can be opened, use objtMessage. Press Enter.
7.Right-click the newly created key, and then click Modify.
8.In the Value data box, type the number of objects that you want to limit this entry to, and then click OK. For example, type 350 to increase the value for the object.
9.Restart the Microsoft Exchange Information Store service.
However, for some instances, the in question user may tell you that only Outlook is in use and there is no other live MAPI sessions he know. Based on my experience, this issue can occur due to third-party add-ins on Outlook or some third-party search indexing software on the Outlook client. To verify this issue, you can run Windows in Clean Boot mode (better to temporarily remove the searching software) and run Outlook without add-ins by Outlook /safe.
In summary, the 9646 Event reports are just the notification about the status of each Exchange Client that connect to the mailbox store. The user impacts may not be huge and you can choose different countermeasures according to the conditions.
More details:
http://support.microsoft.com/kb/842022
https://technet.microsoft.com/en-us/library/ff477612(v=exchg.141).as